ShapePrimsProc

Primitive drawing function for elements and library parts.

    typedef GSErrCode  ShapePrimsProc (
        const API_PrimElement*     primElem,
        const void*                par1,
        const void*                par2,
        const void*                par3
    );

 

Parameters

primElem
The primitive element to draw; can also contain control codes.
par1
First parameter for drawing the element (can be nullptr).
par2
Second parameter for drawing the element (can be nullptr).
par3
Third parameter for drawing the element (can be nullptr).

 

Return Values

NoError
The element was drawn successfully.
APINOTIFY_NODATA
Supress hierarchical decomposition.
APINOTIFY_OWN_MEMORY_HANDLER Featuring API 14
Tells the API that your add-on took over the ownership of the passed coords, pends and parcs array.
For lines, polylines and polygons only.
APIERR_GENERAL
Any user-defined error can be returned.

For other common errors see the list of error codes.

 

Remarks

This function is used to draw the primitive elements. As such, it plugs into the server application’s drawing routines. It can also be used to save the contents of a plan into an external file.

API_PrimTypeID

par1

par2

par3

API_PrimPointID

nullptr

nullptr

nullptr

API_PrimLineID

nullptr

nullptr

nullptr

API_PrimArcID

nullptr

nullptr

nullptr

API_PrimTextID

nullptrAPI version 21

(unsigned short*) pointer to the text (UniCode string) or nullptr

nullptr

API_PrimPLineID

(API_Coord*) coordinates

nullptr

(API_PolyArc*) arcs

API_PrimTriID

nullptr

nullptr

nullptr

API_PrimPolyID

(API_Coord*) coordinates

(Int32*) subpolygon endpoints

(API_PolyArc*) arcs

API_PrimCtrl_BegID

nullptr

nullptr

nullptr

API_PrimCtrl_HatchBorderBegID

(API_PrimHatchBorder*) border

nullptr

nullptr

API_PrimCtrl_HatchBorderEndID

nullptr

nullptr

nullptr

API_PrimCtrl_HatchLinesBegID

nullptr

nullptr

nullptr

API_PrimCtrl_HatchLinesEndID

nullptr

nullptr

nullptr

API_PrimCtrl_HoledimLinesBegID

nullptr

nullptr

nullptr

API_PrimCtrl_HoledimLinesEndID

nullptr

nullptr

nullptr

API_PrimCtrl_ArrowBegID

nullptr

nullptr

nullptr

API_PrimCtrl_ArrowEndID

nullptr

nullptr

nullptr

API_PrimCtrl_ElementRefID

(API_PrimElemRef*) reference

nullptr

nullptr

API_PrimCtrl_EndID

nullptr

nullptr

nullptr

API_PrimCtrl_PlacedBorderBegID

nullptr

nullptr

nullptr

API_PrimCtrl_PlacedBorderEndID

nullptr

nullptr

nullptr

API_PrimCtrl_TextBegID

nullptr

nullptr

nullptr

API_PrimCtrl_TextEndID

nullptr

nullptr

nullptr

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Callback.h

 

See Also

API_PrimElement
API_PrimElemRef
API_PrimHatchBorder
ACAPI_LibPart_ShapePrims
ACAPI_Element_ShapePrims
API Functions