Visual Override

Overview

This feature of the Archicad allows one to create criteria based visual overrides.

Handler functions

Please refer to the functions below the header of a thematic group to have details on that topics.

The following functions let you manipulate API_OverrideCombinations.

ACAPI_Override_GetOverrideCombinationList
ACAPI_Override_GetOverrideCombination
ACAPI_Override_CreateOverrideCombination
ACAPI_Override_ChangeOverrideCombination
ACAPI_Override_DeleteOverrideCombination

The following functions let you manipulate API_OverrideRules.

ACAPI_Override_GetOverrideRuleList
ACAPI_Override_GetOverrideRule
ACAPI_Override_CreateOverrideRule
ACAPI_Override_ChangeOverrideRule
ACAPI_Override_DeleteOverrideRule

Others:

ACAPI_Element_GetActualOverrideStyle lets you query the merged override style for an element.
The API_NavigatorView structure now contains the currently active override combination. Getters and setters of API_NavigatorView also affect the active override combination.