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Dear Reader,

The purpose of this Icon Style Guide is to list and detail all
the rules that we have established for ARCHICAD 20’s
new look and to cover how we work when we design icons
for the new UI.

This document is a handbook for both GRAPHISOFT’s Product
Designers and ARCHICAD Add-On manufacturers to help
maintain a consistent visual appearance for the icons in our
products that we want to reserve in the future.

To understand all important aspects of this document,
you should read it sequentially. Do not skip any section!

We included a lot of examples and explanatory texts in all
sections. Refer to it whenever you are in doubt!

Examine all the descriptions and supplementary material
to understand the correlation between the different sections.

Even though ARCHICAD is incredibly diverse, from dialogs
to palettes and toolbars, we always apply consistent design
principles as described in the following pages.

Enjoy

INTRODUCTION



Step 1:

 Get an overall view by going through the PRINCIPLES.

Step 2:

Learn the style related rules for different attributes such
 as colors, fills, etc. by using the STYLE GUIDE MANUAL.

Step 3:

Choose your tool, set up your work environment and learn
 the necessary tools by using the TOOL MANUAL.

Step 4:

Learn the system side requirements such as location(s)
 and size by using the ARCHICAD STANDARDS.

Step 5:

Create your icon by using the STEP BY STEP TUTORIAL.
If needed, use existing elements from the ASSET LIBRARY.

Step 6:

Check and save your work by using the SAVING AS SVG
 TURORIAL.

HOW TO USE
THIS DOCUMENT



Step 1:

PRINCIPLES
 Get an overall viewof the fundamental visual guiding principles for ARCHICAD icons.



PRINCIPLES/

USERS

 Your primary consideration
 should always the User!
 Design your GUI elements
 by finding out what they want
 to do in that particular UI
 and then create your icons
 so they can carry out that
 task as quickly as possible!

 For example:

 A complex feature, guided
 by rigid technical rules may
 look really complicated
 and hard to understand.

 Perhaps some friendlier,
easy to understand design

 would be more appropriate
 for new users who aren’t
 quite familiar with ARCHICAD.
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PRINCIPLES/

ENVIRONMENT

 Environment refers not only
 to the platform (PC, Mac) you
 design for, but also how it will
 be operated and the physical
 space that it will be used in.

 For example:

Monitors (ARCHICAD) have
 a completely different set
 of variables compared
 to mobile phones or tablets
 (BIMx, BIMcloud Manager).
 They are viewed from
 a different distance, almost
 always used indoors,
 and operated without touch.

 This in turn means different
 considerations for things
 like size, ratio and graphical
 contrast within the icon.
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PRINCIPLES/

COPY AND PASTE

 What you say in your design
 is just as important as how it
 looks. It is important to keep
 stlye as consistent as possible!
 A good copy of used GUI
 elements can not only make
 ARCHICAD easier and quicker
 to understand, but also gives
 it personality through the tone
 of voice used.

 Speaking to people like human
 beings, rather than machines,
 creates an emotional link that
 results in a better UX.

 For example:

 Feel free to copy and paste
 existing elements. If you want
 to say ‘Add’, than use the ‘ASSET
 LIBRARY’ as a source. Do not
 invent what already exists!

NEWAC20
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PRINCIPLES/

WORKING WITH COLOR
AND SHAPES

 Certain colors and shapes
 have become synonymous
 with specific meanings in UX
 design. Be mindful of these
 norms, as mixing them up
 can cause confusion for users.

 For example:

 Green and checkmarks
 are commonly used to indicate
 good, while red and X marks
 are bad, but jumbling the two
 up creates a mixed message.
 Similarly, yellow and triangles
 are often associated with
 warnings, and black and
 circles with info.

DO THIS!
IT’S NICE!

DON’T DO THIS!
IT’S NAUGHTY!

WARNING

INFO

DELETE
(Data loss)

REMOVE
FROM

1:1 3:1 1:1 3:1
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1:1 3:1 1:1 3:1

PRINCIPLES/

FONT AND TYPOGRAPHY

 - Make it easy to read!

 - Make enough space around it!

 - Use the DIN Pro Regular Font!

Follow these steps to create text:

 - Use ‘Outline Stroke’ to make
    the desired text vectorized!

 - Add 0.5 px as the line’s weight! 

 - After outlining, align path
    to grid vertically and each
    letter horizontally!

NICENAUGHTY
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(Object > Path > Outline Stroke)

Lots of information is conveyed
through text, so letters are also
important in UX. Apply the same
principles for a good design: 

1.    This is how a text looks like using
 the DIN Pro Regular font.



1:1 3:1 1:1 3:1

PRINCIPLES/

ALIGMENT

SPACING

 Besides getting everything
 sharp, the other very important
 aspect for pixel perfection
 is making sure the alignment
 is right.

 For example:

 Use graphical alignments
 that helps the viewer quickly

identify and understand what
 an icon means.

 Use icon spacing on the UI
 that communicates hierarchy
 and group the functions by type
 to help the user orientate.

NICENAUGHTY
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1:1 3:1 1:1 3:1

PRINCIPLES/

CONSISTENCY

 Alignment of objects within
 icons and across different
 surfaces is just as important.

 Margins and placement
 of common GUI elements
 such as ‘Settings’, ‘Teamwork
 Reserved Status’ or a ‘Pen’
 should be the same through
 out the interface to prevent
 objects from jumping around.

 For example:

 Follow what is in the ‘Asset
 Library’, and copy existing
 elements which can be used
 throughout several icons.

NICENAUGHTY

1
2
3
4
5
6
7
8
9

10
11
12
13
14
15
16
17
18
19
20



1:1 3:1 1:1 3:1

PRINCIPLES/

CLARITY

 Keep icons as clear as possible
 to avoid overloading the user
 with too much content or
 useless information.

 You can do this by following
‘Form Follows Function’ rule.

 For example, use only one
 of the following at a time:

  - distinguishing mark,

 - highlight color,

 - dashed line (type),

 - special color,

 - strokes or fills,

 Do not change the original
 metaphor but try to be creative!

NICENAUGHTY
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PRINCIPLES/

CLARITY

 Following this idea we decided
 to designed a new style based
 on 3 linetypes, 3 basic colors
 and a rounding effect. Colors
 and lines help to express the
 functionality,  while rounded
 corners help to achieve friendy
 and uniform look. 

 At the same time, we realized
 that colors are important,
 but too much color can go
 against a clean look. To avoid
 a coloring book effect, we
 decided to use only one blue
 accent color to highlight
 a function most of the time.
 Other colors are used for
 specific functions like red for
 indicating deletion or green
 for new elements in Teamwork.
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Step 2:

STYLE GUIDE MANUAL
Learn the style related rules for the different attributes such as colors, fills, etc. 



NAUGHTY

No stroke, only fill.

NICE

Stroke with fill.

STYLE GUIDE MANUAL/

FILL

 - Keep all the icons hairlined!
    Use fills only if it is a must,
    especially if you design a
    menu icon (inverse effect
    on Mac).

 - If you may find it necessary
    to use fills anyway, than keep
    it simple! Draw them with
    a stroke weight line 1-2 px
    and avoid fills that are too
    large.
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STYLE GUIDE MANUAL/

STROKE

- Stroke reference line has
   to be aligned to middle!

(Window > Stroke > Align stroke)

- In case of a 1 px line,
   the reference line has to be

in the middle of a pixel!

 - In case of a 2 px line,
   the reference line has to be

on the pixel grid!

NAUGHTY NICE

1 px stroke aligned on grid

2 px stroke aligned with grid
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1 px stroke not aligned on grid

2 px stroke not aligned with grid



- Use fillet for line ends. Always
    make them rounded!

(Window > Stroke > Cap/Corner)

 - For larger elements, use
   enhanced fillet with effect!
   Always set radius to 1 px!

(Effect > Round Corner)

NICE

10:1
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NAUGHTY
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- Draw lines only with 1 or 2 px
    weight!

.
 - Use thin lines with a weight
   of 1 px as an average!

- Use thick lines with a weight
   of 2 px to emphasize!

 - Keep it simple! Avoid mixing
   up line weights!

STYLE GUIDE MANUAL/

DASHED LINES

- Dashed/dotted lines can
    be horizontal, vertical
   or slanted.

- They have to be drawn
   ‘by hand’ and fixed to grid!

- No golden rule just make
    it easy to read!

NICE

1:1

NAUGHTY

1:1
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#263238

#297FFF

#FFFFFF

#92989B

#FAFAFA

#E5F3FF
#297FFF

#ECECEC
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STYLE GUIDE MANUAL/

COLORS

- Basic dark blue (#263238)
    to draw simple contours.

 - Light grey (#92989B)
    to distinguish a function.

 - Blue color (#297FFF) to
   emphasize, white (#FFFFFF)
   to use ordenary fill.

 - To fill element(s) that are
    higher up in the Navigator:

  - View Map: light blue
     (#E5F3FF),

     - Project Map, Layout Book
     and Publisher Set:
     light  grey (#ECECEC),

 - Lower in the Navigator:    

 - Off white (#FAFAFA),

1:1 3:1



STYLE GUIDE MANUAL/

COLORS

 - Use the colors such as

     light green,

     green,

     to show selection, or for
     Teamwork related icons
     and the

     light blue,

     yellow,

     purple,

     pink,

     red,

     orange

   to emphasize or distinguish.

#B8D8FF

#14FF73

#FFE214

#06A647

#FF14B8

#fd8014

#FF4114

#9D24FF
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1 px 3 px

STYLE GUIDE MANUAL/

SECTION AND SPECIAL FILL

- Draw sections by hand!

- Use the angle of 45° and 1px
as the stroke’s line weight!

- The line density has to be
1 px - 3 px - 1 px - 3 px - ...!

NICE

1:1 3:1

Strokes aligned with grid
(1 px - 3 px)

NAUGHTY

1:1 3:1

Strokes not aligned with grid

SECTION

SPECIAL
FILL

(1 px - 2 px/1 px - 4 px)
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- Draw special fills by hand!

- Use the angle of 0° and 1px
    as the stroke’s line weight!

 - The line density has to be
1 px - 1 px - 1 px - 1 px - ...!

1:1 3:11:1 3:1



STYLE GUIDE MANUAL/

3D

- Draw 3D by hand!

- Use the following 3 types
to visualize elements in 3D:

Type 1:

Standard Axonometry

Type 2:

Frontal Axonometry

 Type 3:

Isometric Axonometry

- Use Type 1 or 2 for function
    /feature/module etc!

- Use Type 2. in case
for technical illustration!

NICENAUGHTY

1:1 3:1 1:1 3:1

Standard Axonometry

Frontal Axonometry

Isometric Axonometry
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~35°
~10°

6 px
1 px 3 px

7 px

30°30°

45°

7 px
6 px 6 px

12 px

12 px
7 px

7 px



STYLE GUIDE MANUAL/

SPECIAL POINTS

- Draw special points by hand!

 Type 1: Edit points

- White dot on black cross.

- Stroke line weight is 1 px.

- To highlight a function that
     relates to a certain point
     in 2D/3D!

 Type 2: Selection points

- Black dot with black fill
     and stroke.

  - Stroke line weight is 1 px.

- Use it to highlight a point
of an object in 2D/3D!

NICENAUGHTY

1:1
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Do not mix them up with other type of points or marks!

- 5 by 5 px cross with a 1 px white
   dott in the middle,
- 4 by 4 px dott with 1 px radius
   rounded corners,
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STYLE GUIDE MANUAL/

GAPS

- Draw at least 1 px gaps
by hand!

- Use them if it is necesary
    to represent elements
    of an icon in 3D to show
    or emphasize its essential
    meaning!

ELEMENT HIERARCHY

- Draw gaps by hand!

- Do not draw lines which
    are not visible!

 - Do not use ‘Clipping Mask’!

- Teamwork ‘Reserved’ green
    elements always have to be
    at the bottom left corner
    of the icon.

NICENAUGHTY
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STYLE GUIDE MANUAL/

21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40

ARROWS

- Draw arrows by hand!

- Use the angle of 90° for
    the arrowhead and 1px
    as the stroke’s line weight!

1:1 3:1

90°

1 px

90°

1 px

1:1 3:1

- Draw the arrow head line
   lenght to 5 px.



STYLE GUIDE MANUAL/

DIALOG ILLUSTRATIONS

ARCHICAD 20ArchiCAD 19
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1 px, #263238

2 px, #297fff

1 px, #263238, ‘Arrow type’:9

1 px, 3-3-3-3 px, #263238

1 px, 1-2-1-2 px, #263238

3-3-3-3 px, #92989b

2 px, #263238

1px, 2-1-2-1 px, #263238

2-1-2-1 px, #92989b

1 px, #92989b

2 px, #92989b
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ILLUSTRATION IN ARCHICAD 20



ARCHICAD 20 PREVIEW



Step 3:

TOOL MANUAL
Choose your tool, set up your work environment and learn it functions.



TOOL MANUAL/

SET UP PREFERENCES IN
ADOBE ILLUSTRATOR

Set ‘Keyboard Increment’
 to 0,5 px!

(Edit > Preferences > General)

 Set Grid density to 1 px
 and subdivisions to 2 px!

(Edit > Preferences > Guides & Grid)

 Set Units to ‘Pixels’!

(Edit > Preferences > Units)
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TOOL MANUAL/

NECESSARY TOOLS

 1. Selection Tool (V)

 2. Direct Selection Tool (A)

 3. Pen Tool (P)

 4. Type Tool (T)

 5. Rectangle Tool (M)

 6. Scissors Tool (C)

 7. Eyedropper Tool (I)

 8. Artboard Tool (Shift+O)

 9. Color Selection Tool
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TOOL MANUAL/

NECESSARY WINDOWS

 10. Transfrom

 11. Stroke

 12. Swatches

 13. Align

 15. Pathfinder

 16. Layers

 17. Appearance

 18. Effect/Stylize/Round Corner
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TOOL MANUAL/

SET UP PREFERENCES 

Set ‘Keyboard Increment’
 to 0,5 px!

(Edit/Preferences > Behavior > Steps)

 Set Grid density to 1 px
 and subdivisions to 2 px!

(Edit > Preferences > Grids)

 Set Units to ‘Pixels’!

(File > Document Properties > Page
> Custom Size > Units)
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TOOL MANUAL/

NECESSARY TOOLS

 1. Select and Transform
     Objects

 2. EditPath by Nodes

 3. Create Rectangle
     and Squares

 4. Draw Bezier Curves
     and Straight Lines

 5. Create and Edit Text
     Objects

 6. Fill Bounded Areas

 7. Pick Colors from Image

 8. Cut Selection
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TOOL MANUAL/

NECESSARY WINDOWS

 9. Fill and Stroke

 10. Icon Preview

 11. Align and Distribute

 12. Layers
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Step 4:

ARCHICAD STANDARDS
Learn the ARCHICAD side requirements for your icon(s) - such as UI location and size.



Icons have to be only hairlined
for good visibility even under
selection highlight. Try to use
no fill for these types of icons!

Menu

ARCHICAD STANDARDAS/

MENU ICONS

 - Canvas Size: 18x18 px,

TOOLBAR ICONS:

 - Canvas Size: 18x18 px,

Toolbar

18
 p

x

18 px

18 px

18
 p

x
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ARCHICAD STANDARDAS/

PALETTE ICONS

 - Canvas Size: 25x20 px, 17x9 px,

POPUP ICONS

 Mac:

 - Canvas Size: 20x20 px,

 WIN:

 - Canvas Size: 18x18 px,
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Palettes

Popup List WIN
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Popup List Mac
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ARCHICAD STANDARDAS/

DIALOG ICONS

 - Canvas Size: 18x18 px,

ROLL-DOWN ICONS

 - Canvas Size: 20x20 px,

LIST ICONS

 - Canvas Size: 30x18 px,
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Dialog
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ARCHICAD STANDARDAS/

TREE ICONS

 - Canvas Size: 18x18 px,

TOOL-BOX ICONS

 - Canvas Size: 18x18 px
    for standard size monitors

and 36x24 px for retina
    display monitors.
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Retina
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Info Box
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ARCHICAD STANDARDAS/

INFO BOX ICONS:

 Push Button Icons:

 - Canvas Size: 34x24 px,

 Popup Button Icons:

 - Canvas Size: 34x24 px,

 Radio Button Icons:

 - Canvas Size: 34x24 px,

 Pop-up Icons:

 - Canvas Size: 18x18 px,

 Panel Illustrations:

 - Canvas Size: 33x33 px,
    36x24, 37x34 px,   
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Step 5:

STEP BY STEP TUTORIAL
An example study about the icon design process.



STEP BY STEP TUTORIAL/

ADOBE ILLUSTRATOR

 This Adobe Illustrator step by
 step tutorial shows you how
 to create a proper ARCHICAD
 toolbar icon. You can use this
 process  to create all kinds
 of icons.

 Step 1: Create a new file:
 ‘File/New...’

Important:

 - Name: ‘NewIcon_18x18’

    Width: 18 px,

    Height: 18 px,

 - Units: Pixels,

 - Document Color Mode: RGB,

‘File/Document Color Mode/RGB color’

New File
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STEP BY STEP TUTORIAL/

 Step 2: Set up your Work
 Environment.

 Suggestions:

 - Use the 

‘Snap to Grid’
    function.

‘View/Snap to Grid’

 - Turn on the 

‘Show Grid’
    option.

‘View/Show to Grid’

 - Turn on the 

‘Ruler’ function.‘View/Rulers/Show Rulers’

View Menu

41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58



Pixel Preview

STEP BY STEP TUTORIAL/

 Step 3: Draw the icon while
 keeping the content within
 the canvas!

 Step 4: Check your work by
 using the Pixel Preview feature.

‘View/Pixel Preview’

 Step 5: Save your work as an
 SVG

.See related topic on page 34.
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Document Properties

STEP BY STEP TUTORIAL/

INKSCAPE

 This Inkscape step by step
 tutorial shows you how to
 create a proper ARCHICAD
 toolbar icon. You can use this
 process to create all kinds
 of icons.

 Step 1: Create a new file: Start
 Inkscape or go to ‘File/New...’

 Step 2: Set up Canvas Size
 and Units.

- Canvas Size: 18x18 px,

 - Units: px,

‘File/Document Propetries’
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View Menu

STEP BY STEP TUTORIAL/

 Step 3: Set up your Work
 Environment.

 Suggestions:

 - Turn on the ‘Page Grid’
    option.

‘View/Page Grid’

 - Turn on the ‘Ruler’ function.

‘View/Show/Hide Rulers’
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Icon Preview

STEP BY STEP TUTORIAL/

 Step 4: Draw the icon while
 keeping the content within
 the canvas!

 Step 5: Check your work by
 using the Icon Preview feature.

‘View/Icon Preview...’

 Step 6: Save your work as
 an SVG

.See related topic on page 43.
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Step 6:

SAVE AS SVG TUTORIAL
Check and save your work as SVG.
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SAVE AS SVG TUTORIAL/

QUALITY CHECK IN ILLUSTRATOR

 - Always check your work!

 - Arrange vectors to have
    the best pixelized view
    for the icon!

 - Use ‘Ctrl + Alt + Y’ for pixel
    preview!

VECTOR IMAGE

RASTERIZED IMAGE

NAME SVG AS FOLLOWS:

‘filename_[widthnumber]x[heightnumber].svg’

NICENAUGHTY



SAVE AS SVG TUTORIAL/

SAVE AS SVG ILLUSTRATOR

 - To export an SVG, go to:

File > Save As

 - Use the following options
    on the SVG Options panel:

 ‘CSS Propetries: Presentation
 Attributes’

 - You can check the SVG code
    by clicking on “SVG Code...”!

 For further information,
    please go to:

http://wiki/w/B-379_New_Vectorial_Icon_Format_for_HDPI
_Display/Specifik%C3%A1ci%C3%B3
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SAVE AS SVG TUTORIAL/

QUALITY CHECK IN INKSCAPE

 - Always check your work!

 - Arrange vectors to have
    the best pixelized view
    for the icon!

 - Use the ‘Icon Preview’ panel!

SAVE AS SVG IN INKSCAPE

 - To export an SVG, go to:

File > Save As

    For further information,
    please go to:

http://wiki/w/B-379_New_Vectorial_Icon_Format_for_
HDPI_Display/Specifik%C3%A1ci%C3%B3
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NAME SVG AS FOLLOWS:

‘filename_[widthnumber]x[heightnumber].svg’

VECTOR IMAGE

RASTERIZED IMAGE

NICENAUGHTY



ASSET LIBRARY
A collection of predesigned, reusable content.



ELEMENT 1:1 HOW TO USE 1:1ASSET LIBRARY/

 - Arrow

 Use the ‘Smyle Effect’ when
 it is possible!

 - Mouse Cursor

 - Plane

 - Settings/Propetries/Options

Different appearance in UI
 and in menu!

 - Folder

 - Save

 - Change/Modify/Adjust

 - Camera type 1.

 - Camera type 2.

 - File

 - Lock

 - Unlock

 - Glass

 - Pen

 - Image

 - Module

 - Error

 - Level Arrow

 - Printer

 - 3D house

 - 2D house

 - Drag Arrow

 - Refresh element type 1.

    Action/Status/Animation

 - Refresh element type 2.

 - List

 - Wall

 - Paint/Surface

 - Monitor/Display

 - User

 - Earth/Globe

 - Shortcut

 - Message

 - Delete/Cancel/Erase

 - Remove (element or data)

 - Apply/Validate/OK
   /Default option

 -  Chain

 - Picker

 - Warning

 - Add/Create (new element)

 - Delete element

 - Clock

 - Arrow 

 - Settings

 - Schedule/Calendar

 - (Element) Selection

 - Info

 - Disabled

 - Material

 - Tools

- Tools from Add-Ons example

on UI

Tools in Toolbar: Tools in Menu:
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