ACAPI_​AddOnObject_​GrantObjects

In teamwork mode this function grants the specified objects to the given user.

    GSErrCode  ACAPI_AddOnObject_GrantObjects (
        const GS::Array<API_Guid>&     objectGuids,
        short                          toUserId
    );

 

Parameters

objectGuids
[in] The list of the objects which must be granted.
toUserId
[in] The teamwork owner, to which the objects must be granted.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuids is empty or contains APINULLGuid.
APIERR_BADID
If any of the objectGuids is not an AddOnObject GUID.

For other common API errors see the API Errors document.

 

Remarks

If the function has completed with success then the specified objects will be granted to the given user. The process runs in silent mode, no dialogs or messages will interrupt.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions