APIDb_​RebuildWindowValidatorID

Sets the element and checksum list for an already added validator with given guid.

    GSErrCode ACAPI_Database (
        APIDb_RebuildWindowValidatorID,
        const API_WindowValidatorInfo*       pValidatorInfo
    );

 

Parameters

pValidatorInfo
Contains the guid of a window which is the owner of the validator and the new element and checksum list.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
pValidatorInfo is nullptr
APIERR_MEMFULL
Not enough memory to complete the operation.
APIERR_GENERAL
There is no validator registered for this guid.

For other common API errors see the API Errors document.

 

Remarks

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database
API Functions