API Structures

API_3D_Head
API_3DCutPlanesInfo
API_3DCutShapeType
API_3DFilterModeID  API 20 feature
API_3DFilterAndCutSettings
API_3DModelTypeID
API_3DProjectionInfo
API_3DSightID
API_3DStyle  API 21 feature
API_3DTypeID
API_3DUncutSurfaceFillType
API_3DWindowInfo
 
API_ActionCenterItemID  API 25 feature
 
API_ActTranPars
API_AddOnCommand  API 25 feature
API_AddOnCommandExecutionPolicy  API 25 feature
API_AddOnInfo
API_AddonType
API_AddParID
API_AddParType
API_AnalyticalCrossSection  API 24 feature
API_AnalyticalCurve  API 24 feature
API_AnalyticalCurveMember  API 24 feature
API_AnalyticalCurveType  API 24 feature
API_AnalyticalCylinderSurface  API 24 feature
API_AnalyticalElemPartId  API 24 feature
API_AnalyticalLinkGeometry  API 24 feature
API_AnalyticalLink_RigidSettings  API 24 feature
API_AnalyticalLink_Rotation  API 24 feature
API_AnalyticalLink_Settings  API 24 feature
API_AnalyticalLink_SpringSettings  API 24 feature
API_AnalyticalLink_Translation  API 24 feature
API_AnalyticalLinkType  API 24 feature
API_AnalyticalLoadCase  API 25 feature
API_AnalyticalLoadCaseActionType  API 25 feature
API_AnalyticalLoadCaseDuration  API 25 feature
API_AnalyticalLoadCaseLoadType  API 25 feature
API_AnalyticalLoadGroup  API 25 feature
API_AnalyticalLoadGroupRelation  API 25 feature
API_AnalyticalLoadGroupType  API 25 feature
API_AnalyticalLoadCombinationCategory  API 25 feature
API_AnalyticalLoadCombinationNationalStandard  API 25 feature
API_AnalyticalLoadFactor  API 25 feature
API_AnalyticalLoadCombination  API 25 feature
API_AnalyticalMemberPartRef  API 24 feature
API_AnalyticalMemberType  API 24 feature
API_AnalyticalModelVariation  API 24 feature
API_AM_VisibilityMode  API 26 feature
API_LoadVisibilityMode  API 26 feature
API_AM_VisibilitySettings  API 26 feature
API_AnalyticalNode  API 24 feature
API_AnalyticalPlaneSurface  API 24 feature
API_AnalyticalReleaseDescription  API 24 feature
API_AnalyticalReleaseType  API 24 feature
API_AnalyticalSupportGeometry  API 24 feature
API_AnalyticalSupport_Settings  API 24 feature
API_AnalyticalSupport_SettingValues  API 24 feature
API_AnalyticalSupportType  API 24 feature
API_AnalyticalCoordSysDirection  API 25 feature
API_AnalyticalLoad_LoadDistributionType  API 25 feature
API_AnalyticalPointLoad_Settings  API 25 feature
API_AnalyticalPointLoadType  API 25 feature
API_AnalyticalEdgeLoad_Settings  API 25 feature
API_AnalyticalEdgeLoadType  API 25 feature
API_AnalyticalSurfaceLoad_Settings  API 25 feature
API_AnalyticalSurfaceLoadType  API 25 feature
API_AnalyticalLinkGeometry  API 25 feature
API_AnalyticalSurface  API 24 feature
API_AnalyticalSurfaceMember  API 24 feature
API_AnalyticalSurfaceType  API 24 feature
API_AnalyticalVaryingSegment  API 26 feature
API_AnchorID
API_AngleDimensionType
API_AngleDimFormat
API_AngleTypeID
API_AMPartRefCustomVertexData  API 25 feature
API_AMPartRefRatioEdgeData  API 25 feature
API_AppearID
API_ApplicationTypeID
API_ArcType
API_AreaDimFormat
API_AreaTypeID  API 22 feature
API_ArrowData
API_ArrowID
API_AssemblySegmentCutData Featuring API 17
API_AssemblySegmentCutTypeID Featuring API 17
API_AssemblySegmentData Featuring API 17
API_AssemblySegmentLengthTypeID Featuring API 17
API_AssemblySegmentProfileData Featuring API 17
API_AssemblySegmentSchemeData Featuring API 17
API_AssemblySegmentUniformityID Featuring API 17
API_Attr_Head
API_Attribute
API_AttributeDef
API_AttributeDefExt
API_AttributeFolder  API 26 feature
API_AttributeFolderContent  API 26 feature
API_AttributeIndex
API_AttributeReplaceIndexTable  API 25 feature
API_AttributeUserData
API_AttrTypeID
API_AutotextType
API_AxonoPars
 
API_Base
API_Beam_Hole
API_BeamPart
API_BeamSegmentType Featuring API 23
API_BeamSegmentQuantity Featuring API 23
API_BeamShapeTypeID Featuring API 23
API_BeamQuantity
API_BeamRelation
API_BeamSegmentRelation Featuring API 23
API_BeamType
API_BHoleTypeID
API_BodyType
API_Box
API_Box3D
API_BreakLineAngleTypeID
API_BreakLinePositionTypeID
API_BuildingMaterialType
 
API_CalcAngleFormat
API_CalcAreaFormat  API 22 feature
API_CalcLengthFormat  API 22 feature
API_CalcVolumeFormat  API 22 feature
API_CalcUnitPrefs
API_CalcRulesPrefs
API_CameraType
API_CamSetType
API_ChangeMarkerLinkType
API_ChangeMarkerType
API_ChangeParamType
API_CircleLevelDimensionFillID Featuring API 22
API_CircleType
API_IClassificationItemEventHandler Featuring API 26
API_IClassificationSystemEventHandler Featuring API 26
API_IGraphisoftIDEventHandler Featuring API 26
API_IPropertyDefinitionEventHandler Featuring API 26
API_IPropertyGroupEventHandler Featuring API 26
API_ClipTran
API_ColorDepthID
API_ColorModeValues
API_ColumnSegmentType Featuring API 23
API_ColumnSegmentQuantity Featuring API 23
API_ColumnQuantity
API_ColumnType
API_Component3D
API_ComponentID  API 25 feature
API_CompositeQuantity
API_CompositeQuantityMask
API_CompWallType
API_ConditionalElementPropertyTypeID  API 25 feature
API_ConditionalElementRule  API 25 feature
API_ConnectionGuidItem
API_ConstraintPars
API_ConstraintType
API_ContentPars
API_ContourEdgeData
API_ConvModID
API_Coord
API_Coord3D
API_CoverFillTransformation API 23 feature
API_CoverFillTransformationTypeID API 23 feature
API_CrossSectionType  API 24 feature
API_CursorFormID
API_CursorSet
API_CurtainWallModelViewOptions  22
API_CurtainWallQuantity
API_CurtainWallType
API_CutPlaneMarkerShowType
API_CutPlanePlanConn
API_CutPlaneShowType
API_CutPlaneType
API_CutPlPlanConn
API_CutPlaneUncutSurfaceFillID
API_CWAccessoryCategoryID
API_CWAccessoryQuantity
API_CWAccessoryType
API_CWallComponent
API_CWFrameType
API_CWJunctionType
API_CWallLineComponent
API_CWPanelType
API_CWSegmentType
API_CWBoundaryFramePosID
API_CWContourData
API_CWFrameAncestryType
API_CWFrameCategory
API_CWFrameObjectTypeID
API_CWFrameQuantity
API_CWGridLineAssignType
API_CWJunctionCategoryID
API_CWJunctionClampFrameOrientationID
API_CWJunctionQuantity
API_CWPanelObjectTypeID
API_CWPanelQuantity
API_CWPlacement_Type
API_CWSegmentBoundaryFramePosType
API_CWSegmentCategoryID
API_CWSegmentGridLineAssignType
API_CWSegmentGridOrigPosTypeID
API_CWSegmentType
 
API_DailyProfile
API_DailyProfileUsage
API_DashItems
API_DatabaseInfo
API_DatabaseTypeID
API_DatabaseUnId
API_DescriptorRefType
API_DescriptorType
API_DetailType
API_WorksheetType
API_DimBase
API_DimElem
API_DimensionAttrType
API_DimensionPrefs
API_DimensionType
API_DimOriginID
API_DirID
API_DocumentFrom3DDefaults
API_DocumentFrom3DType
API_DocumentSourceID
API_DoorQuantity
API_DoorType
API_DrawingLinkInfo
API_DrawingLinkTypeID
API_DrawingTitle
API_DrawingType
 
API_EdgeLoadCustomData
API_EdgeTrim
API_EdgeTrimID
API_EdgeType
API_EditCmdID
API_EditPars
API_ElemDisplayOptionsID
API_Element
API_ElementDBEventID
API_ElementDecomposerInterface
API_ElementMemo
API_ElementUserData
API_ElementQuantity
API_ElementQuantityMask
API_ElemComponentID  API 25 feature
API_ElemFilter
API_ElemInfo3D
API_ElemPartQuantity
API_ElemPartCompositeQuantity
API_ElemProjectionModesID  22
API_ElemSearchPars
API_ElemType  22
API_ElemTypeID
API_ElemURLRef
API_ElemVariationID
API_ElemViewDepthLimitationsID
API_Elem_Head
API_ElemCategoryID  API 19 feature
API_ElemCategory  API 19 feature
API_ElemCategoryValue  API 19 feature
API_ElemDifferenceGeneratorTypeID  API 19 feature
API_ElemDifferenceGeneratorStateType  API 19 feature
API_ElemDifference  API 19 feature
API_ElemDifferenceGeneratorState  API 19 feature
API_EnvironmentID
API_EnvirParams
API_ESYMParams
API_ExportIdMappingType  API 24 feature
API_ExtendedPenType
API_ExtraAccuracyID
API_ExtrudedShellData
 
API_Favorite  API 23 feature
API_FileOpenPars
API_FileSavePars
API_FillLine
API_FillOrientationID
API_FillSubtype
API_FilltypeType
API_FloorPlanCutDefinition
API_FontType
API_FTypeID
 
API_Gable
API_GDLModelViewOptions
API_GeoLocation
 API 25 feature
API_GeoReferenceData  API 25 feature
API_GetArcType
API_Get3DComponentType
API_GetLineType
API_GetParamsType
API_GetParamValuesType
API_GetPointType
API_GetPolyType
API_GhostRecord
API_GhostStoryType
API_GridEdgeInfo
API_GridMesh
API_GridMeshDirection
API_GridMeshEdge
API_GridMeshHead
API_GridMeshLine
API_GridMeshPolygon
API_GridMeshVertex
API_GridType
API_Guid
 
API_HatchFlags
API_HatchOrientation
API_HatchOrientationTypeID
API_HatchQuantity
API_HatchSubType
API_HatchType
API_HoleDim
API_HotlinkCacheGenerator
API_HotlinkNode
API_HotlinkStoryRangeID
API_HotlinkTypeID
API_HotlinkUserData
API_HotspotType
API_HourlyProfile

 
API_IFCAttribute
API_IFCClassificationReference
API_IFCClassification
API_IFCDifference API 23 feature
API_IFCEntityDescriptor API 23 feature
API_IFCProperty
API_IFCPropertyAnyValue
API_IFCPropertyBoundedValue
API_IFCPropertyEnumeratedValue
API_IFCPropertyHead
API_IFCPropertyListValue
API_IFCPropertySingleValue
API_IFCPropertyTableValue
API_IFCPropertyValue
API_IFCRelationshipData API 23 feature
API_IFCTranslatorIdentifier API 23 feature
API_IfcTypeID API 20 feature
API_ImagingAndCalcPrefs
API_ImportIdMappingType API 24 feature
API_InitNeigFilterID
API_InteriorElevationType
API_InternalAnalyticalMemberPartId API 24 feature
API_Interval
API_IOParams
API_ImageViewID API 20 feature
 
API_JustID
 
API_KeyType
 
API_LabelType
API_LampType
API_LayerCombType
API_LayerStat
API_LayerType
API_LayoutBook
API_LayoutInfo
API_LayoutsPrefs
API_LblAnchorID
API_LblClassID
API_LegacyPrefs
API_LengthDimFormat
API_LengthTypeID  API 22 feature
API_LevelDimensionType
API_LghtSouID
API_LghtType
API_LibPart
API_LibPartDetails
API_LibPartSection
API_LibraryInfo
API_LibraryTypeID
API_LibTypeID
API_LightQuantity
API_LineItems
API_LinePositionID
API_LineType
API_LinetypeType
API_LinkToSettings
API_LinkType
API_ListData_Head
API_ListData
API_ListDataID
API_ListDataSetType
API_ListVariant  API 20 feature
API_LocalCoordsData
API_LocalCoordsType
API_LtypItemID
API_LtypTypeID
 
API_MagicWandInfo
API_MarkerData
API_MarkerID
API_MarkerLinkDataType
API_MarkUpCommentType  API 21 feature
API_MarkUpCommentStatusID  API 21 feature
API_MarkUpComponentTypeID  API 26 feature
API_MarkUpType  API 21 feature
API_MaterialType
API_MaterTypeID
API_MDCLParameter
API_MDSetCmd
API_MenuItemRef
API_MenuParams
API_MEPSystemType
API_MeshLevel
API_MeshLevelCoord
API_MeshQuantity
API_MeshType
API_MimePicture
API_MiscAppInfo
API_MiscPlotterInfo
API_MiscPrinterInfo
API_ModelElemStructureType
API_ModelViewOptions
API_StairModelViewOptions
API_ModelViewOptionsType
API_ModulData
API_ModulID
API_MonolithPartsVisibilityData  API 21 feature
API_MorphBodyTypeID
API_MorphEdgeTypeID
API_MorphingRuleID
API_MorphType
 
API_NameTypeValues
API_NavigatorID  API 22 feature
API_NavigatorAddOnViewPointData  API 22 feature
API_NavigatorAddOnViewPointTypeID  API 22 feature
API_NavigatorItem
API_NavigatorItemTypeID
API_NavigatorMapID
API_NavigatorSet
API_NavigatorView
API_NavigatorViewSettingsFlags  API 22 feature
API_Neig
API_NeigFilter
API_NeigID
API_NewProjectPars
API_NewWindowPars
API_Niche
API_NoteAutotextID  API 26 feature
API_NoteContentType
API_NoteType
API_NotifyElementType
API_NotifyEventID
API_NotifyViewEventID
API_NotifyViewEventType
API_NumberingGridLine
API_NumberingStyle
API_NumberingTypeValues
 
API_ObjectQuantity
API_ObjectSettingsPars
API_ObjectType
API_Obsolete_ComponentRefType
API_Obsolete_ComponentType
API_OnScreenViewOptions
API_OpeningBaseType
API_OperationProfileType
API_OpeningType
API_OverriddenAttribute
API_OverriddenAttributeOrRGB  API 25 feature
 
API_ParagraphType
API_ParamOwnerType
API_PedgType
API_PenOverrideType
API_PenTableType
API_PenTableUsageModeValues
API_PenType
API_PersCamSetPars
API_PerspCamPars
API_PerspPars
API_PetPaletteType
API_PgonType
API_PhotoRenderPars
API_PictureFormat
API_PictureHandle
API_PictureType
API_PivotPolyEdgeData
API_PlaceInfo
API_Plane3D
API_PlaneRoofData
API_Point
API_PolyArc
API_Polygon
API_PolyLineType
API_PolyGetMethod
API_PolyRoofData
API_PrefsTypeID
API_Prim_Head
API_PrimArc
API_PrimElement
API_PrimElemRef
API_PrimHatchBorder
API_PrimHotspot
API_PrimLine
API_PrimPict
API_PrimPLine
API_PrimPoint
API_PrimPoly
API_PrimText
API_PrimTri
API_PrimTypeID
API_PrintPars
API_PrintStampType
API_ProfileAttrType
API_ProjectInfo
API_ProjectNoteInfo
API_Property  API 20 feature
API_PropertyDefinition  API 20 feature
API_PropertyGroup  API 20 feature
API_PropertyObjectParams
API_PropertyObjectRefType
API_PropertyValue  API 20 feature
API_PropertyDefaultValue  API 22 feature
API_PropertyConversionUtilsInterface  API 25 feature
API_PublishFormatData  API 23 feature
API_PublishPars
 
API_Quantities
API_QuantitiesMask
API_QuantityPar
 
API_RadialDimensionType
API_RailingBalusterSetType
API_RailingBalusterType
API_RailingDistributionData
API_RailingFinishType
API_RailingFrameData
API_RailingHandrailType
API_RailingHorizontalPosData
API_RailingInnerPostType
API_RailingNodeType
API_RailingPanelType
API_RailingPatternType
API_RailingPostType
API_RailingRailConnectionType
API_RailingRailEndType
API_RailingRailType
API_RailingSegmentType
API_RailingToprailType
API_RailingType
API_RailingVerticalPosData
API_Rect
API_RefLevelsPrefs
API_Region
API_RendEffects
API_RendImage
API_RendSetTypeID
API_RendSetTypeID
API_RenovationStatusType
API_RevolvedShellData
API_SSALevel
API_RiserCrossSectID
API_RiserPositionID
API_RGBAColor
API_RoofClassID
API_RoofEdgeTypeID
API_RoofLevelData
API_RoofOverHangTypeID
API_RoofQuantity
API_RoofSegmentData
API_PolyRoofSegmentAngleTypeID
API_RoofType
API_RoomReductionPolyType
API_RoomRelation
API_RoomImage  API 23 feature
API_RubberArcType
API_RubberLineInfo
API_RubberLineType
API_RubberPolyCallbacks
API_RuledShellData
API_RunType
API_RVMChange
API_RVMDocumentRevision
API_RVMDocumentRevisionStatusID
API_RVMIssue
API_RVMLayoutInfo
 
API_SafetyPrefs
API_SavePars_Archive
API_SavePars_Ifc
API_SavePars_Object
API_SavePars_Picture
API_SavePars_Plandump
API_SectElemType
API_SectionSegment
API_Sector
API_SelectionInfo
API_SelTypeID
API_ServerApplicationInfo
API_SFill_Arc
API_SFill_Line
API_ShadingContoursID
API_SharingInfo
API_ShellBaseContourEdgeTypeID
API_ShellBaseCutBodyTypeID
API_ShellBaseSegmentTypeID
API_ShellBaseType
API_ShellClassID
API_ShellContourData
API_ShellShapeData
API_ShellQuantity
API_ShellType
API_ShowGhostType
API_SideStairStructData
API_SingleVariant  API 20 feature
API_SingleEnumerationVariant  API 20 feature
API_SkeletonOptions
API_SkylightAnchorID
API_SkylightFixModeID
API_SkylightQuantity
API_SkylightType
API_SlabQuantity
API_SlabReferencePlaneLocationID
API_SlabType
API_SolidOperationID
API_SpecFolderID
API_SplineDir
API_SplineType
API_StairBoundaryData
API_StairBoundaryEdgeData
API_StairHeadroomData  API 22 feature
API_StairPolylineVertexData
API_StairDirectionID
API_StairDisplayTypeID
API_StairDLWinderNumTypeID
API_StairGridTypeID
API_StairInnerWidthOffsetTypeID
API_StairLayoutData
API_StairPolylineEdgeData
API_StairNumberingID
API_StairStructureComponentSettingsVisibility  API 21 feature
API_StairStructureComponentSettingsVisibilityOnStory  API 21 feature
API_StairPolyGeometryTypeID
API_StairPolylineData
API_StairPolyTypeID
API_StairRiserType
API_StairRulesData
API_StairSegmentTypeID
API_StairStructBottomTypeID
API_StairStructHeightMeasureID
API_StairStructureType
API_StairTreadNosingTypeID
API_StairTreadType
API_StairTurnTypeID
API_StairType
API_StairBoundaryVertexData
API_StairWinderNumTypeID
API_StoryCmdID
API_StoryCmdType
API_StoryHandleAppearance
API_StoryInfo
API_StoryType
API_StoryVisibility
API_StructureDisplay
API_SubElement API 25 feature
API_SubElementType API 25 feature
API_SubSet
API_SunAngleSettings API 21 feature
API_SunAngleSettings_SunPositionOption API 21 feature
API_SunInfo
API_Surface3D
API_SymbolHatchDef
API_SyTran
 
API_TabID
API_TabType
API_TestSplineFit
API_TexCoordPars
API_TextLinePars
API_TextPosID
API_TextType
API_Texture
API_TextureProjectionTypeID
API_TitlePreviewModes
API_Token  API 26 feature
API_ToolBoxInfo
API_ToolBoxItem
API_ToolCmdID
API_Tranmat
API_TranslatorNameConfig
API_TrimTypeID
 
API_UCCallbackType
API_UIStructureDisplay
API_UmatType
API_UniformAttributeOptions
API_UnitConversionData
API_UnitConversionPrefID
API_UnitType
API_UserControlType
API_UserData
API_UserInfo
API_UVCoord
API_Variant  API 20 feature
API_VariantStatus  API 22 feature
 
API_Vector
API_Vector3D
API_VectorShadowID
API_VectType
API_VeneerTypeID
API_VerticalLink
API_VerticalLinkID
API_VertType
API_ViewNodeTypeID
API_ViewOptions
API_ViewSourceID
API_VisualOverriddenImage API 20 feature
API_VLNumType
API_VolumeTypeID  API 22 feature
 
API_WallPart
API_WallQuantity
API_WallRelation
API_WallType
API_WallTypeID
API_WindowDoorDirectionTypes
API_WindowInfo
API_WindowValidatorInfo  API 22 feature
API_WindowQuantity
API_WindowType
API_WindowTypeID
API_WitnessID
API_WorkingUnitPrefs  API 22 feature
API_Wrapping
 
API_ZoneCatType
API_ZonePrefs
API_ZoneAllQuantity
API_ZoneRelID
API_ZoneType
 
APIMenuCodeID