ACAPI_​Property_​GetPropertyGroups

Retrieves all the property groups.

    GSErrCode  ACAPI_Property_GetPropertyGroups (
        GS::Array<API_PropertyGroup>&     groups
    );

 

Parameters

groups
[out] The retrieved property groups.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Example



GSErrCode GetPropertyGroupNames (GS::Array<GS::UniString>& names)
{
    GS::Array<API_PropertyGroup> groups;
    GSErrCode error = ACAPI_Property_GetPropertyGroups (groups);
    
    if (error == NoError) {
        for (UInt32 i = 0; i < groups.GetSize (); i++) {
            names.Push (groups[i].name);
        }
    }

    return error; 
}

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions