ACAPI_​Classification_​GetClassificationSystem

Retrieves a classification system identified by its guid or by its name and edition version.

        GSErrCode  ACAPI_Classification_GetClassificationSystem (
            API_ClassificationSystem&      system
        );
    

 

Parameters

system
[in] The system.guid or the system.name and system.editionVersion together that identify the classification system to retrieve.
[out] The retrieved classification system.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The system.guid is not null and did not refer to a valid classification system or the system.name and system.editionVersion together did not refer to a valid classification system.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions