Represents a Handrail element.
typedef struct { API_Elem_Head head; API_Guid owner; API_Guid symbID; bool visible; bool doubleHandrail; bool filler_1[6]; double horizontalOffset; double height; } API_RailingHandrailType;
Members
- head
- General element header.
- owner
- GUID of the Railing Segment element owning this Handrail.
- symbID
- The identifier of the symbol of this element.
- visible
- True, if the Handrail is visible.
- doubleHandrail
- True, if the Handrail is relative.
- horizontalOffset
- The horizontal offset of the Handrail from the Segment.
- height
- The height of the Handrail element.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_Element, API_RailingType,
API_RailingSegmentType
Element Manager, API Types