ACAPI_​AnalyticalModel_​GetAnalyticalLoadCases

Returns an array of unique identifiers of the existing Load Cases from a Load Group.

    GSErrCode  ACAPI_AnalyticalModel_GetAnalyticalLoadCases (
        const API_Guid&          analyticalLoadGroupGuid,
        GS::Array<API_Guid>&     analyticalLoadCases
    );

 

Parameters

analyticalLoadGroupGuid
[in] The unique identifier of the Load Group.
analyticalLoadCases
[out] Array of unique identifiers.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 25 or later
Header: ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions