ACAPI_​AnalyticalModel_​GetCurveElements

Returns the elements that have Structural Analytical Model Curve Member associated.

    GSErrCode  ACAPI_AnalyticalModel_GetCurveElements (
        const API_Guid&          amGuid,
        GS::Array<API_Guid>&     curveElements
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
curveElements
[out] The list of Curve Element unique identifiers.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions