APIEnv_​Create3DStyleID

Creates a new 3D style.

    GSErrCode ACAPI_Environment (
        APIEnv_Create3DStyleID,
        API_3DStyle*     style
    );

 

Parameters

style
[in] Parameters of a new 3D style

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
style is nullptr, or a some parameter of the style is invalid, or a style with the same name already exists.
APIERR_NOPLAN
No open project.
APIERR_NOACCESSRIGHT
The user does not have Teamwork privilege to create a 3D style.

For other common API errors see the API Errors document.

 

Remarks

The newly created style is not applied upon creation. To set the new style as active use APIEnv_SetCurrent3DStyleID.

See an example at the description of APIEnv_Get3DStyleListID.

 

Requirements

Version: API 21 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions,
APIEnv_Get3DStyleListID,
APIEnv_Get3DStyleID,
APIEnv_Change3DStyleID,
APIEnv_SetCurrent3DStyleID,
API_3DStyle