ACAPI_​Attribute_​RemoveClassificationItem

Removes a classification from an attribute.

    GSErrCode  ACAPI_Attribute_RemoveClassificationItem (
        const API_Attr_Head&        attrHead,
        const API_Guid&             itemGuid
    );

 

Parameters

dt>attrHead
[in] Header of the attribute. The attribute is identified by typeID and index
itemGuid
[in] The guid of the classification item, that should be removed from the attribute.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
The attrHead did not refer to a valid attribute.
APIERR_READONLY
The attribute can not be modified (i.e. from a hotlink) or you do not have the right to remove classifications from attributes in the current teamwork plan.
APIERR_BADID
Inexistent classification item.
APIERR_BADPARS
The attribute did not have the specified classification.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version:API 23 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions