API_​CWFrameObjectTypeID

Curtain wall frame object type.

    typedef enum {
        APICWFrObjectType_Invisible,
        APICWFrObjectType_GDL,
        APICWFrObjectType_InvisibleConnectedTurning,
        APICWFrObjectType_InvisibleConnectedStill
    } API_CWFrameObjectTypeID;

 

Members

APICWFrObjectType_Invisible
APICWFrObjectType_Generic
APICWFrObjectType_ButtGlazed
APICWFrObjectType_GDL
APICWFrObjectType_InvisibleConnectedTurning
APICWFrObjectType_InvisibleConnectedStill

 

Remarks

The API_CWFrameObjectTypeID type is used in the API_CWFrameType structure. The APICWFrObjectType_Generic and APICWFrObjectType_ButtGlazed types have been removed in Archicad 22.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWFrameAncestryType, API_CWFrameCategory
API_CWFrameType, API Types