ACAPI_​Element_​GrantElements

In teamwork mode this function grants the specified elements to the given user.

    GSErrCode  ACAPI_Element_GrantElements (
        const GS::Array<API_Guid>&     elemGuids,
        short                          toUserId
    );

 

Parameters

elemGuids
[in] The list of the elements which must be granted.
toUserId
[in] The teamwork owner, to which the objects must be granted.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter elemGuids is empty, contains APINULLGuid, or not all the elements are on the same floor.
APIERR_BADID
If any of the elemGuids is not an AddOnObject GUID.

For other common API errors see the API Errors document.

 

Remarks

If the function has completed with success then the specified elements will be granted to the given user. The process runs in silent mode, no dialogs or messages will interrupt.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

Element Manager, API Functions