APIPropertyVisibilityHandlerProc

Callback function to handle the visibility of a property.

    typedef bool  APIPropertyVisibilityHandlerProc (
        API_PropertyVisibilityMode     visibilityMode,
        const GS::Array<API_Guid>&     classificationGuids,
        const API_Guid&                propertyDefinitionGuid
    );

 

Parameters

visibilityMode
[in] specifies what should the callback function return. Has one of the following values:

API_PropertyVisibilityMode

Meaning

APIPropVis_IsEnabled

The callback function should return true if the visibility handling is enabled.

APIPropVis_IsPropertyVisible

The callback function should return true if the given property is visible.

classificationGuids
[in] the classification guids of the current element.
propertyDefinitionGuid
[in] the guid of the current property.

 

Return Values

The result.

For other common API errors see the API Errors document.

 

Example



static bool __ACENV_CALL PropertyVisibilityHandler (API_PropertyVisibilityMode visibilityMode,
                                                    const GS::Array<API_Guid>& classificationGuids,
                                                    const API_Guid& propertyDefinitionGuid)
{
    if (visibilityMode == APIPropVis_IsEnabled) {
        // returns true if the property visibility handling enabled, false otherwise
        // ...
    } else if (visibilityMode == APIPropVis_IsPropertyVisible) {
        // returns true if the property should be shown, false otherwise
        // ...
    }

    return true;
}

 

Requirements

Version: API 21 or later
Header: APIdefs_Callback.h

 

See Also

Classification and Property Visibility
API Functions