API_​ElemVariationID

Describes the subcategory of an element.

    typedef enum {
        APIVarId_Generic,
        APIVarId_SymbStair,
        APIVarId_WallEnd,
        APIVarId_Door,
        APIVarId_Skylight,
        APIVarId_Object,
        APIVarId_GridElement,
        APIVarId_Light,
        APIVarId_CornerWindow
    } API_ElemVariationID;

 

Members

APIVarId_Generic
Generic element.
APIVarId_SymbStair
Stair (object subtype).
APIVarId_WallEnd 5.1
Wall End (window subtype).
APIVarId_Door 20
Door (opening subtype).
APIVarId_Skylight 20
Skylight (opening subtype).
APIVarId_Object 20
Generic object.
APIVarId_GridElement 20
Grid element.
APIVarId_Light 20
Generic light.
APIVarId_CornerWindow 20
Corner window.

 

Remarks

API_ElemVariationID is an extension of typeID (see API_Elem_Head). These are built in subcategories. But if you register an own subtype with ACAPI_Register_Subtype function you have to pass at first a four-character identifier the variationID (your signature). This is an arbitrary long value wherewith you can identify your own subtype. It is used only in case of library elems (object, lamp, window, door).

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Elements.h

 

See Also

API Types
Library Part Subtypes