It generates an IFC Difference based on the input parameters.
GSErrCode ACAPI_Goodies ( APIAny_GetIFCDifferenceID, API_IFCDifferenceGeneratorState* previousIFCDifferenceGeneratorState, API_IFCDifferenceGeneratorState* currentIFCDifferenceGeneratorState, API_IFCDifference* ifcDifference );
Parameters
- previousIFCDifferenceGeneratorState
- [in] Previous IFCDifference Generator state.
- currentIFCDifferenceGeneratorState
- [in] Current IFCDifference Generator state.
- ifcDifference
- [out] The resulting IFC Difference.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- If any error occured during the conversion.
For other common API errors see the API Errors document.
Remarks
It generates an IFC Difference based on the input parameters.
Requirements
- Version: API 23 or later
- Header: APIdefs_Goodies.h