ACAPI_​Attribute_​GetClassificationInSystem

Retrieves a classification of an attribute in a given classification system.

    GSErrCode  ACAPI_Attribute_GetClassificationInSystem (
        const API_Attr_Head&        attrHead,
        const API_Guid&             systemGuid,
        API_ClassificationItem&     item
    );

 

Parameters

attrHead
[in] Header of the attribute. The attribute is identified by typeID and index
systemGuid
[in] The guid of the classification system in which the classification item should be retrieved.
item
[out] The retrieved classification item (empty with null guid if the elem doesn’t have a classification in the given system).

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
APIERR_DELETED
The attrHead did not refer to a valid attribute.
APIERR_BADID
Inexistent classification system.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version:API 23 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions