API_​BeamRelation

Structure for retrieving connection data of a beam.

    typedef struct {
        API_Coord                          **coords;
        Int32                              **pends;
        API_PolyArc                        **parcs;
        Int32                              filler_1;
        API_Polygon                        connPoly;
        GS::Array<API_ConnectionGuidItem>  *conBeg;
        GS::Array<API_ConnectionGuidItem>  *conEnd;
        GS::Array<API_ConnectionGuidItem>  *conRef;
        GS::Array<API_ConnectionGuidItem>  *con;
        GS::Array<API_ConnectionGuidItem>  *conX;
        GS::Array<API_BeamSegmentRelation> *segmentRelations;
        Int32                              filler_2[5];
        Int32                              filler_3[5];
    } API_BeamRelation;

 

Members

coords
Coordinates of the modified outline polygon
pends
Indices of the end coordinates of the subpolygons
parcs
Arc segments of the modified outline polygon (used with curved beams API 17)
connPoly
Modified outline polygon due to the connections
conBeg
List of beams connected to the beginning point of the beam with their beginning or end point (see figure).
conEnd
List of beams connected to the end point of the beam with their beginning or end point (see figure).
conRef
List of beams connected with their reference line to the beginning or the end point of the beam (see figure).
con
List of beams connected to the reference line of the beam not at the endpoints (see figure).
conX
List of beams having intersection with the reference line of the beam (see figure).
segmentRelations
List of relations of the beam’s segments.

 

Explanatory figure for beam relation cases

 Beam relation

 

Remarks

To learn more about the usage of the beam relation structure please refer to the ACAPI_Element_GetRelations function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetRelations, API_BeamSegmentRelation, API_WallRelation, API_CWPanelRelation, API_ConnectionGuidItem, API_Coord, API_PolyArc, API_Polygon, API Types