APINavigator_​ChangeNavigatorVPItemID

Changes an existing Navigator viewpoint root, group or leaf node in the Project Map.

    GSErrCode ACAPI_Navigator (
        APINavigator_ChangeNavigatorVPItemID,
        const API_NavigatorAddOnViewPointData*     viewPointData
    );

 

Parameters

viewPointData
[in] Details of the viewpoint root, group or leaf node to be modified.
The guid member designates which item to modify. The other members should hold the new values.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
viewPointData was nullptr.
APIERR_BADID
viewPointData.guid designetes an object which does not exist, or it is not a Navigator viewpoint root, group or leaf node of the current AddOn.
APIERR_NOACCESSRIGHT
The function was called in teamwork mode, and a root or group was to be modified.
APIERR_NOTMINE
In teamwork mode, the current user has not reserved the viewpoint root, group or leaf node designated by viewPointData.guid.

For other common API errors see the API Errors document.

 

Remarks

viewPointData.parentGuid is ignored, i.e. the hierarchy cannot be changed with this function.

viewPointData.itemType is ignored, i.e. the type of the object to change is determined by viewPointData.guid.

viewPointData.viewSettingsFlags is ignored, if viewPointData.parentGuid designates a root or a group.

Note: In teamwork mode you cannot create, change or delete viewpoint roots or groups.

 

Requirements

Version: API 22 or later
Header: APIdefs_Navigator.h

 

See Also

ACAPI_Navigator,
API Functions