API_​VectType

Representation of a 3D normal vector.

    typedef struct {
        API_3D_Head     head;
        double          x;
        double          y;
        double          z;
    } API_VectType;

 

Members

head
Header information of this component. This specifies the type and database index.
x, y, z
The 3 coordinates of the vector in the model space.

 

Remarks

This structure is used to describe a normal vector of a polygon. If you get a polygon of a body, you will get an index (ivect field of API_PgonType structure) to an API_VectType structure. Use this index in the head.index field to get the normal vector of that polygon.

Note: In the case of closed bodies, they point from the inside to the outside of the body. Normal vectors of an open body must point to the same side of the body.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_3D.h

 

See Also

API_3D_Head, API_Component3D,
3D Manager, API Types