ACAPI_​IFC_​IFCGuidToAPIGuid

It converts an API_Guid to an IfcGloballyUniqueId string.

    GSErrCode ACAPI_IFC_IFCGuidToAPIGuid (
        GS::UniString&      ifcGuid,
        const API_Guid&     apiGuid
    );

 

Parameters

ifcGuid
[in] IfcGloballyUniqueId string need to be converted.
apiGuid
[out] The resulting API_Guid.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
If any error occured during the conversion.

For other common API errors see the API Errors document.

 

Remarks

It converts an IfcGloballyUniqueId string to API_Guid.

For example “32vZ_y6Kf8bQUeOicmrSnx” is converted to “C2E63FBC-194A-4895-A7A8-62C9B0D5CC7B”.

 

Requirements

Version: API 26 or later
Header: API_Guid.hpp

 

See Also

ACAPI_IFC_APIGuidToIFCGuid