Returns the Structural Analytical Edge Load Geometry.
GSErrCode ACAPI_AnalyticalModel_GetAnalyticalEdgeLoadGeometry ( const API_Guid& amGuid, const API_Guid& elemGuid, API_EdgeLoadCustomData& api_analyticalEdgeLoadGeometry );
Parameters
- amGuid
- [in] The unique identifier of the internal Structural Analytical Model.
- elemGuid
- [in] The unique identifier of the internal Curve Element.
- api_analyticalEdgeLoadGeometry
- [out] The Structural Analytical Edge Load geometry.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Requirements
- Version: API 25 or later
- Header: ACAPI_Analytical_Adapter.hpp