APIEnv_​IsAutoIntersectOnID

Returns the state of the automatic wall intersection flag.

    GSErrCode ACAPI_Environment (
        APIEnv_IsAutoIntersectOnID,
        bool*     isOn
    );

 

Parameters

isOn
Tells whether the automatic intersection of walls is turned on.

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
No open project.
APIERR_BADPARS
The isOn parameter is nullptr.

For other common API errors see the API Errors document.

 

Remarks

This flag was part of the Display Options in previous (pre-10) API versions. With the separation of the Display Options from Display and Output Options, automatic intersection has started its own ‘life’.

Its value can be modified with APIEnv_ChangeAutoIntersectID.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_ChangeAutoIntersectID, ACAPI_Environment,
API Functions