API_​SavePars_​Pdf

Contains the different page options for saving to pdf file.

    typedef struct {
        float     leftMargin;
        float     topMargin;
        float     rightMargin;
        float     bottomMargin;
        float     sizeX;
        float     sizeY;
        Int32     filler_1[4];
    } API_SavePars_Pdf;

 

Members

leftMargin
The size of the left margin in mm in pages.
topMargin
The size of the top margin in mm in pages.
rightMargin
The size of the right margin in mm in pages.
bottomMargin
The size of the bottom margin in mm in pages.
sizeX
The horizontal size of the page in mm.
sizeY
The vertical size of the page in mm.

 

Remarks

If you want to save the content of a window, the type of the file fileTypeID in API_FileSavePars should be set to APIFType_PdfFile. In case of 3D and Master Layout Archicad will export the floor plan.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

API_FileSavePars,
API Types