ACAPI_​AnalyticalModel_​GetCurveMember

Returns the Structural Analytical Model Curve Member associated with the selected Curve Element.

    GSErrCode  ACAPI_AnalyticalModel_GetCurveMember (
        const API_Guid&                amGuid,
        const API_Guid&                elemGuid,
        API_AnalyticalCurveMember&     cm
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Curve Element.
cm
[out] The Structural Analytical Model Curve Member data.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions