API_​IClassificationItemEventHandler

The base class you need to inherit from in case you want to handle API_ClassificationItem events.

    class API_IClassificationItemEventHandler : public API_IEventHandler {
    public:
        virtual void OnCreated (const GS::HashSet<API_Guid>& ids) const;
        virtual void OnModified (const GS::HashSet<API_Guid>& ids) const;
        virtual void OnDeleted (const GS::HashSet<API_Guid>& ids) const;
    };

 

Functions

OnCreated
Override this function to be notified of newly created Classification Items.
OnModified
Override this function to be notified of modified Classification Items.
OnDeleted
Override this function to be notified of deleted Classification Items.

  

Requirements

Version: API 26 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Notify_RegisterEventHandler
API_ClassificationItem,
API Types