Frees the memory occupied by all of the allocated room relation handles.
GSErrCode ACAPI_DisposeRoomRelationHdls ( API_RoomRelation* roomInfo );
Parameters
- roomInfo
- [in] Points to an API_RoomRelation structure which contains handles used for previous operations and not needed any more.
Return Values
NoError
- The function has completed with success.
Remarks
This is the recommended way of disposing the room relation handles for compatibility reasons, as in a later version of the API the API_RoomRelation structure might change.
Requirements
- Version: API 1.3 or later
- Header: ACAPinc.h
See Also
API_RoomRelation,
ACAPI_Element_GetRelations,
Memory Manager, API Functions