ACAPI_​Element_​GetIFCAttributes

Get IFC attributes of an element

    GSErrCode  ACAPI_Element_GetIFCAttributes (
        const API_Guid&                  guid_Element,
        bool                             storedOnly,
        GS::Array<API_IFCAttribute>*     attributes
    );

 

Parameters

guid_Element 
[in] GUID of the element
storedOnly API 19 feature
[in] Get only the core data without the derived content, must be false is most cases
attributes 
[out] IFC attributes of the element

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter or attributes is nullptr.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function returns the IFC attributes of an element.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SetIFCAttribute