ACAPI_​Element_​IsPropertyDefinitionAvailableDefault

Tells whether a property definition is available for an element default.

    bool  ACAPI_Element_IsPropertyDefinitionAvailableDefault (
        const API_ElemType&     type,
        const API_Guid&         propertyGuid
    );

 

Parameters

type
[in] Type of the default element.
propertyGuid
[in] The property definition GUID to search for.

 

Return Values

true
The given property definition is available for the element default.
false
The given property definition is not available for the element default.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example


GSErrCode GetAvailablePropertyDefinitions (const API_ElemType& type, GS::Array<API_PropertyDefinition>& availableProperties)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions);
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); ++i) {
            if (ACAPI_Element_IsPropertyDefinitionAvailableDefault (type, definitions[i].guid)) {
                availableProperties.Push (definitions[i]);
            }
        }
    }
    return error;
}
        

Note: this example function is identical to calling ACAPI_Element_GetPropertyDefinitionsOfDefaultElem, and you should use it if you need this functionality.

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions