APIEnv_​GetNavigatorParentItemID

Retrieves the parent item of a navigator item.

    GSErrCode ACAPI_Environment (
        APIEnv_GetNavigatorParentItemID,
        const API_Guid*        guid,
        API_NavigatorItem*     parent
    );

 

Parameters

guid Changed in API 11
[in] The GUID of the navigator item
parent
[in/out] The parent item of the navigator item (you should set mapId for performance).

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The guid or the parent parameter is nullptr, or contains invalid data.
APIERR_GENERAL
No open project.

 

Remarks

This function is used to get the parent node of a given item of the Project Navigator.

 

Example

See the example of APIEnv_SearchNavigatorItemID.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Environment.h

 

See Also

API_NavigatorItem
APIEnv_GetNavigatorItemID
APIEnv_GetNavigatorChildrenItemsID
ACAPI_Environment
API Functions