API_​ArcType

Represents an elliptical or circular arc.

    typedef struct {
        API_Elem_Head           head;
        API_ExtendedPenType     linePen;
        API_AttributeIndex      ltypeInd;
        bool                    roomSeparator;
        bool                    filler_1[5];
        short                   determination;
        API_ArrowData           arrowData;
        double                  penWeight;
        char                    filler_2[16];
        Int32                   filler_3[8];
        API_Coord               origC;
        double                  r;
        double                  angle;
        double                  ratio;
        double                  begAng;
        double                  endAng;
        bool                    reflected;
        bool                    whole;
        short                   filler_4;
        Int32                   filler_5[7];
    } API_ArcType;

 

Members

head
General element header.
linePen 20
(Overridden) pen attribute index.
ltypeInd
Line type attribute index.
roomSeparator
Is this arc a zone boundary?
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options. Also, lines in the Skin Separator category can be optionally placed onto their own layer during DXF/DWG conversion functions.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

arrowData
Arrow data for the arc ends.
penWeight
Pen weight for the arc (can override the weight in linePen, otherwise set it to API_DefPenWeigth: use default weight of the pen).
origC
Coordinate of the center point.
r
Radius.
angle
0.0, or the angle of the ‘a’ axis.
ratio
1.0, or ‘a/b’ of the ellipse.
begAng
Beginning angle of the arc.
endAng
End angle of the arc.
reflected
Is the ellipse reflected onto the smaller axis?
whole
Is this a whole arc? (output only)

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Elem_Head, API_ArrowData, API_Coord, API_ExtendedPenType, API_Element,
Element Manager, API Types