API_​CompositeQuantity

Describes the different calculated values for skins of composite or complex elements.

    typedef struct {
        API_CompositeId     compositeId;
        double              volumes;
        double              projectedArea;
        API_AttributeIndex  buildMatIndices;
        short               flags;
    } API_CompositeQuantity;

 

Members

compositeId 21
Identifies the composite skin and sub-element.
volumes
Volumes of consecutive skins of composite or complex elements (in the order defined by the fill indexes).
projectedArea 19
The projected area of consecutive skins of composite or complex elements (in the order defined by the fill indexes). Its value is 0 if the Use Legacy intersection and Surface methods for model elements is turned on in the Project Preferences, because the special 3D model used to calculate this information cannot be created in legacz mode.
buildMatIndices 17
Building materials of consecutive skins of composite or complex elements.
flags
The flags of consecutive skins of composite or complex elements (in the order defined by the fill indexes). See the flagBits in API_CWallComponent.

 

Requirements

Version: API 19 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities,
API_CompositeId, API_ElementQuantity, API_QuantityPar, API Types