APIAny_​ChangeMDCLParameterID

Modifies a parameter on the parameter list.

    GSErrCode ACAPI_Goodies (
        APIAny_ChangeMDCLParameterID,
        GSHandle               params,
        API_MDCLParameter*     mDCLParameter
    );

 

Parameters

params
[in/out] Handle of the parameter list
mDCLParameter
[in] Pointer to the modified parameter

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
params or par is nullptr,
or par->type is invalid or does not match the type of the parameter on the list
APIERR_BADNAME
The passed parameter name is not found on the parameter list
APIERR_BADINDEX
The passed parameter index is out of range (checked only if par->name is nullptr)

 

Remarks

This function is used to modify a parameter on the parameter list handle used in inter-addon communications.
For the utilization details of APIAny_ChangeMDCLParameterID refer to the Parameter Passing section of the Communication Manager.

 

Example

See the Communication_Client example.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
API_MDCLParameter
APIAny_AddMDCLParameterID
APIAny_FreeMDCLParameterListID
APIAny_GetMDCLParameterID
APIAny_GetMDCLParameterNumID
APIAny_InitMDCLParameterListID
ACAPI_Command_Call
ACAPI_Command_Test
ACAPI_Goodies
API Functions