API_​PedgType

Representation of a 3D edge reference.

    typedef struct {
        API_3D_Head     head;
        Int32           pedg;
        Int32           filler_1;
    } API_PedgType;

 

Members

head
Header information of this component. This specifies the type and database index.
pedg
Edge reference. Negative value means opposite direction. Zero index identifies a new hole.

 

Remarks

The edges in the 3D model are stored in a list. The value of pedg field is an index to the items of that list.

If you go through the edge reference list from fpedg to lpedg, you can obtain the edges of a polygon. (The fpedg and lpedg available in the API_PgonType record, after you got a polygon of a body by calling ACAPI_3D_GetComponent function.) The pedg field is an index of an API_EdgeType structure which represents an edge.

The orientation of the edge list is counterclockwise (mathematical positive), if you are looking at it from the outside of the body. The orientation of the holes is opposite to that of the parent polygon.

If pedg is negative, it means the referred edge direction is reversed.

If pedg is zero, it means a contour end; a hole follow.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_3D.h

 

See Also

API_PgonType, API_EdgeType, API_3D_Head, API_Component3D,
3D Manager, API Types