API_​CircleType

Represents a circle or an ellipse.

    typedef struct {
        API_Elem_Head           head;
        API_ExtendedPenType     linePen;
        API_AttributeIndex      ltypeInd;
        bool                    roomSeparator;
        bool                    filler_1[5];
        short                   determination;
        double                  penWeight;
        char                    filler_2[16];
        Int32                   filler_3[8];
        API_Coord               origC;
        double                  r;
        double                  angle;
        double                  ratio;
        Int32                   filler_4[8];
    } API_CircleType;

 

Members

head
General element header.
linePen 20
(Overridden) pen attribute index.
ltypeInd
Line type attribute index.
roomSeparator
Is this circle/ellipse a zone boundary?
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options. Also, lines in the Skin Separator category can be optionally placed onto their own layer during DXF/DWG conversion functions.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

penWeight
Pen weight for the circle/ellipse (can override the weight in linePen, otherwise set it to API_DefPenWeigth: use default weight of the pen).
origC
Coordinate of the center point.
r
Radius.
angle
0.0, or the angle of the ‘a’ axis.
ratio
1.0, or ‘a/b’ of the ellipse.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Elem_Head, API_Coord, API_ExtendedPenType, API_Element,
Element Manager, API Types