APIEnv_​ChangeGhostRecordID

Change the settings of a Virtual Trace (ghost) record.

    GSErrCode ACAPI_Environment (
        APIEnv_ChangeGhostRecordID,
        const API_GhostRecord*     ghostRecord
    );

 

Parameters

ghostRecord
The Trace database to change.

 

Return Values

NoError
The function has completed with success.
APIERR_WINDNOTEXIST
The parent database does not exist.

For other common API errors see the API Errors document.

 

Remarks

Change the settings of the trace record associated with the parent database.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 13 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API_GhostRecord, APIEnv_CreateGhostRecordID, APIEnv_GetGhostRecordID, API Functions