ACAPI_​Property_​GetPropertyDefinitions

Retrieves all the property definitions from a given group.

    GSErrCode  ACAPI_Property_GetPropertyDefinitions (
        const API_Guid&                        groupGuid,
        GS::Array<API_PropertyDefinition>&     definitions
    );

 

Parameters

groupGuid
[out] The identifier of the group to search for or APINULLGuid if all property definitions should be retrieved.
definitions
[out] The retrieved property definitions.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The groupGuid parameter wasn’t APINULLGuid and it did not refer to a valid property group.

For other common API errors see the API Errors document.

 

Example



GSErrCode GetPropertyNames (GS::Array<GS::UniString>& names)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions);
    
    if (error == NoError) {
        for (UInt32 i = 0; i < definitions.GetSize (); i++) {
            names.Push (definitions[i].name);
        }
    }

    return error; 
}

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions