APIDb_​ResetCurrentWindowID

Deletes the database elements of the current window and sets up a new, empty environment.

    GSErrCode ACAPI_Database (
        APIDb_ResetCurrentWindowID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_BADWINDOW
The current database is not a custom drawing or owned by an other addon.

For other common API errors see the API Errors document.

 

Remarks

This function is used to delete all elements from the current window. It returns an error if the active window is not a custom window owned by the caller addon.

You can use the APIDb_ResetCurrentDatabase function to reset the content of any window being in the background.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

APIDb_ResetCurrentDatabase,
ACAPI_Database, API Functions