ACAPI_​Element_​SetIFCProperty

Set IFC property of an element

    GSErrCode  ACAPI_Element_SetIFCProperty (
        const API_Guid&            guid_Element,
        const API_IFCProperty&     property
    );

 

Parameters

guid_Element
[in] GUID of the element
property
[in] IFC property to add or modify.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid value passed in the guid_Element parameter or property is not correct.
APIERR_MODULNOTINSTALLED
IFC add-on is not present.

For other common API errors see the API Errors document.

 

Remarks

This function sets the IFC property of an element.
If a property with the given property name and propertyset name already exists for the element, this command will change it.
If a property is not editable on the user interface, must not be changed.
For a successful setting, the property must be set correctly explained in the API_IFCProperty structure.
The model may contain GDL objects with APPLICATION_QUERYs which display IFC data. It is the developer’s responsability to refresh the views after modifying IFC data through API functions. See: ACAPI_Automation – APIDo_RebuildID function.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_GetIFCProperties
ACAPI_Element_RemoveIFCProperty