ACAPI_​Install_​PublisherSaveMethod

Installs the save methods for the Publisher

    GSErrCode  ACAPI_Install_PublisherSaveMethod (
        const char*  mimeType,
        SaveProc*    saveProc,
    );

 

Parameters

mimeType
The unique mimeType which identifies the new publish format
saveProc
Callback function, called in case of publishing

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function installs the callback functions for the new publish formats. The publisher will call the registered function, during the publishing command.

 

Example

Refer to the Format Register Test example project of the API Development Kit.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

SaveProc
ACAPI_Register_PublishFormat
API Functions