APINavigator_​GetNavigatorChildNumID

Retrieves the number of children of a navigator item.

    GSErrCode ACAPI_Navigator (
        APINavigator_GetNavigatorChildNumID,
        API_NavigatorItem*     parent,
        Int32*                 num
    );

 

Parameters

parent
[in] The requested navigator item identified with GUID (you should set mapId for performance).
num
[out] The number of children of the navigator item

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The parent or the num parameter is nullptr, or contains invalid data.
APIERR_GENERAL
No open project

 

Remarks

This function retrieves the number of child items of a given item of the Project Navigator.

 

Example

See the example of APINavigator_SearchNavigatorItemID.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorItem
APINavigator_GetNavigatorChildrenItemsID
ACAPI_Navigator
API Functions