API_​UIStructureDisplay

This structure represents the Partial Structure Display state.

    typedef struct {
        API_StructureDisplay     structureDisplay;
        API_DatabaseUnId         databaseUnId;
        bool                     is3D;
        bool                     filler[7];
    } API_UIStructureDisplay;

 

Members

structureDisplay
The Partial Structure Display state.
databaseUnId
The identifier of the owner Database.
is3D
The owner is the 3D window.

 

Remarks

You are able to get and change the Partial Structure Display via APIEnv_GetStructureDisplayID and APIEnv_ChangeStructureDisplayID functions.
This function allows you to display and output composite and complex elements in simplified form. All model based database (Model2D, Model3D, Section, Elevation, InteriorElevation, DocumentFrom3D) contains an own Partial Structure Display state.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

API_StructureDisplay, API_DatabaseUnId
API Types