ACAPI_​Install_​AddOnObjectConvertNew​FormatHandler

Installs a callback procedure for converting old format AddOnObject data into current format.

    GSErrCode  ACAPI_Install_AddOnObjectConvertNewFormatHandler (
        APIAddonObjectConvertNewFormatHandlerProc*     convertNewFormatProc
    );

 

Parameters

convertNewFormatProc
[in] The callback procedure to convert AddOnObject data. Passing nullptr in this parameter uninstalls the previously installed handler function.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your add-on to pass the pointer of the APIAddOnObjectConvertNewOldFormatHandlerProc callback routine implemented for converting old format AddOnObjects of the add-on into current format.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

APIAddOnObjectConvertNewFormatHandlerProc
ACAPI_Register_AddOnObjectHandler
AddOnObject Manager
API Functions