API_​PenTableType

Pen table attribute.

    typedef struct {
        API_Attr_Head     head;
        bool              inEffectForModel;
        bool              inEffectForLayout;
        short             filler_1;
        Int32             filler_2[4];
    } API_PenTableType;

 

Members

head
Contains the name, guid and the index of the attribute.
inEffectForModel
The active pen table for the model.
inEffectForLayout
The active pen table for the layout.

 

Remarks

Pen tables are new in Archicad 10, introduced because of the layouting functionality.

Each pen table contains 255 pens. Separate pen tables can be active for the layouting and for the model windows.

The pens of the pentable are passed in the penTable_Items field of the API_AttributeDefExt structure.

 

Requirements

Version: API 10 or later
Header: APIdefs_Attributes.h

 

See Also

API_AttributeDefExt,
API_Attr_Head, API Types