API_​SplineType

Represents a cubic or Bezier-spline.

    typedef struct {
        API_Elem_Head           head;
        API_ExtendedPenType     linePen;
        API_AttributeIndex      ltypeInd;
        bool                    roomSeparator;
        bool                    filler_1[5];
        short                   determination;
        API_ArrowData           arrowData;
        double                  penWeight;
        char                    filler_2[16];
        bool                    autoSmooth;
        bool                    closed;
        short                   filler_3;
        Int32                   filler_4[7];
    } API_SplineType;

 

Members

head
General element header.
linePen 20
(Overridden) pen attribute index.
ltypeInd
Line type attribute index.
roomSeparator
Is this arc a zone boundary?
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options. Also, lines in the Skin Separator category can be optionally placed onto their own layer during DXF/DWG conversion functions.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

arrowData
Arrow data for the arc ends.
penWeight
Pen weight for the arc (can override the weight in linePen, otherwise set it to API_DefPenWeigth: use default weight of the pen).
autoSmooth
Smooth spline automatically, or use the bezierDirs field (of type API_SplineDir) in API_ElementMemo?
closed
Is this a closed curve?

 

Remarks

The coordinates of the spline points are given in the coords field of API_ElementMemo. The last and the first coordinate in coords should be different; and the coordinate with index 0 is also used. If autoSmooth is false, then the handle positions for every spline point are given in the bezierDirs field in API_ElementMemo.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Elem_Head, API_ArrowData, API_Element,
API_SplineDir, API_ExtendedPenType, API_ElementMemo,
Element Manager, API Types