ACAPI_​Element_​GetProperties

Retrieves the specified property definitions with values.

    GSErrCode  ACAPI_Element_GetProperties (
        const API_Guid&              elemGuid,
        GS::Array<API_Property>&     properties
    );

 

Parameters

elemGuid
[in] The element GUID to search for.
properties
[in] Specifies the properties to retrieve. They are identified through definition.guid.
[out] The definitions and values of the requested properties.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemGuid did not refer to a valid element.

For other common API errors see the API Errors document.

 

Example



GSErrCode GetAllPropertyValues (const API_Guid& elemGuid, GS::Array<API_PropertyValue>& values)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitions (elemGuid, definitions);
    if (error == NoError) {
        GS::Array<API_Property> properties;
        for (UInt32 i = 0; i < definitions.GetSize (); i++) {
            API_Property property;
            property.definition = definitions[i];
            properties.Push (property);
        }

        error = ACAPI_Element_GetProperties (elemGuid, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                if (properties[i].isDefault) {
                    values.Push (properties[i].definition.defaultValue);
                } else {
                    values.Push (properties[i].value);
                }
            }
        }
    }

    return error;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions