Returns the Structural Analytical Point Load Geometry.
GSErrCode ACAPI_AnalyticalModel_GetAnalyticalPointLoadGeometry ( const API_Guid& amGuid, const API_Guid& elemGuid, API_AnalyticalPointLoadGeometry& api_analyticalPointLoadGeometry );
Parameters
- amGuid
- [in] The unique identifier of the internal Structural Analytical Model.
- elemGuid
- [in] The unique identifier of the internal Curve Element.
- api_analyticalPointLoadGeometry
- [out] The Structural Analytical Point Load geometry.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Requirements
- Version: API 25 or later
- Header: ACAPI_Analytical_Adapter.hpp