ACAPI_​Install_​NavigatorAddOnViewPointDataConvertNew​FormatHandler

Installs a callback procedure for converting Navigator AddOn viewpoints into current format.

    GSErrCode  ACAPI_Install_NavigatorAddOnViewPointDataConvertNewFormatHandler (
        APINavigatorAddOnViewPointDataConvertNewFormatHandlerProc*     convertNewFormatProc
    );

 

Parameters

convertNewFormatProc
[in] The callback procedure which will handle the Navigator AddOn viewpoints’ conversion into current format. If nullptr is passed, an installed callback function is removed.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your AddOn.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

APINavigatorAddOnViewPointDataConvertNewFormatHandlerProc
ACAPI_Register_NavigatorAddOnViewPointDataHandler
API Functions